好股网 > 股票公式 > 通达信公式

通达信超牛龙头主图及选股指标公式

时间:2019年11月14日 22:07
2019/9/3 20:07:14

涨跌:=REF(C,1);
涨停:=IF(((((C - 涨跌) * 100) / 涨跌) >= (10 - ((0.01 * 100) / 涨跌))),1,0);
DIF:=(EMA(C,12) - EMA(C,26));
DEA:=EMA(DIF,9);
MACD:=((DIF - DEA) * 2);
VAR2:=(CLOSE * VOL);
VAR3:=EMA((((((EMA(VAR2,3) / EMA(VOL,3)) + (EMA(VAR2,6) / EMA(VOL,6))) + (EMA(VAR2,12) / EMA(VOL,12))) + (EMA(VAR2,24) / EMA(VOL,24))) / 4),13);
VAR4:=EMA(CLOSE,9);
飞狐线:=(MA(CLOSE,25) + ((MA(CLOSE,25) * 20) / 100));
强势线:=(MA(CLOSE,25) + ((MA(CLOSE,25) * 6) / 100));
支撑线:=((((MA(CLOSE,3) + MA(CLOSE,6)) + MA(CLOSE,12)) + MA(CLOSE,24)) / 4);
压力线:=EMA((VAR4 * 1.14),5);
盈损线:=(LLV(REF(LOW,1),2) + ((HHV(REF(HIGH,1),2) - LLV(REF(LOW,1),2)) / 2));
QD:=(((C > 强势线) AND (C > 支撑线)) AND (C > 盈损线));
小妖:=((COUNT(QD,10) = 1) AND QD);
XYJJ:=BARSLAST(小妖);
JS:=CROSS(C,压力线);
妖狐:=((COUNT(JS,XYJJ) <= 1) AND JS);
HX1:=((REF(妖狐,1) AND (O > 压力线)) AND (C > 压力线));
HX2:=((REF(妖狐,1) AND CROSS(C,飞狐线)) AND (C > 压力线));
狐仙前世:=(小妖 AND 妖狐);
狐仙金身:=(HX1 OR HX2);
妖狐王:=((((REF(涨停,1) AND (O > 压力线)) AND (O > REF(H,1))) AND (REF(H,1) < REF(压力线,1))) AND (L >= 压力线));
XG:=((狐仙前世 OR 狐仙金身) OR 妖狐王);
AAAA:=MA(C,1);
AAA:=SMA(SMA(SMA(AAAA,2,1),2,1),2,1);
BBB:=MA(AAA,3);
DRAWBAND(AAA,RGB(255,255,0),BBB,RGB(0,0,255));
CCC:=(3*C+L+O+H)/6;
牛线:=(20*CCC+19*REF(CCC,1)+18*REF(CCC,2)+17*REF(CCC,3)+16*REF(CCC,4)+15*REF(CCC,5)+14*REF(CCC,6)+13*REF(CCC,7)+12*REF(CCC,8)+11*REF(CCC,9)+10*REF(CCC,10)+9*REF(CCC,11)+8*REF(CCC,12)+7*REF(CCC,13)+6*REF(CCC,14)+5*REF(CCC,15)+4*REF(CCC,16)+3*REF(CCC,17)+2*REF(CCC,18)+REF(CCC,20))/210,COLORRED,LINETHICK2;
马线:=MA(牛线,5);
DRAWBAND(牛线,RGB(255,40,0),马线,RGB(256,200,0));
STICKLINE(IF((C>REF(C,1)*1.096),2,0),OPEN,CLOSE,3,0),COLORRED;
DRAWTEXT(XG=1,LOW-0.05,'↖超牛龙头'),COLORYELLOW;

{
选股公式:

涨跌:=REF(C,1);
涨停:=IF(((((C - 涨跌) * 100) / 涨跌) >= (10 - ((0.01 * 100) / 涨跌))),1,0);
DIF:=(EMA(C,12) - EMA(C,26));
DEA:=EMA(DIF,9);
MACD:=((DIF - DEA) * 2);
VAR2:=(CLOSE * VOL);
VAR3:=EMA((((((EMA(VAR2,3) / EMA(VOL,3)) + (EMA(VAR2,6) / EMA(VOL,6))) + (EMA(VAR2,12) / EMA(VOL,12))) + (EMA(VAR2,24) / EMA(VOL,24))) / 4),13);
VAR4:=EMA(CLOSE,9);
飞狐线:=(MA(CLOSE,25) + ((MA(CLOSE,25) * 20) / 100));
强势线:=(MA(CLOSE,25) + ((MA(CLOSE,25) * 6) / 100));
支撑线:=((((MA(CLOSE,3) + MA(CLOSE,6)) + MA(CLOSE,12)) + MA(CLOSE,24)) / 4);
压力线:=EMA((VAR4 * 1.14),5);
盈损线:=(LLV(REF(LOW,1),2) + ((HHV(REF(HIGH,1),2) - LLV(REF(LOW,1),2)) / 2));
QD:=(((C > 强势线) AND (C > 支撑线)) AND (C > 盈损线));
小妖:=((COUNT(QD,10) = 1) AND QD);
XYJJ:=BARSLAST(小妖);
JS:=CROSS(C,压力线);
妖狐:=((COUNT(JS,XYJJ) <= 1) AND JS);
HX1:=((REF(妖狐,1) AND (O > 压力线)) AND (C > 压力线));
HX2:=((REF(妖狐,1) AND CROSS(C,飞狐线)) AND (C > 压力线));
狐仙前世:=(小妖 AND 妖狐);
狐仙金身:=(HX1 OR HX2);
妖狐王:=((((REF(涨停,1) AND (O > 压力线)) AND (O > REF(H,1))) AND (REF(H,1) < REF(压力线,1))) AND (L >= 压力线));
((狐仙前世 OR 狐仙金身) OR 妖狐王);
}