好股网 > 股票公式 > 通达信公式

通达信MACDKDJ指标公式

时间:2019-09-17 21:34:15

周DI:(EMA(CLOSE,60)-EMA(CLOSE,130)),NODRAW;
周DE:EMA(周DI,25),NODRAW;
周DIF:=20*周DI;
周DEA:=20*周DE;
DRAWBAND(周DIF,RGB(139,0,139),周DEA,RGB(0,100,50));
XG2:=CROSS(周DEA,0);
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:(DIF-DEA)*40,COLORSTICK;
DIFF:20*DIF,COLORWHITE;
DEAA:20*DEA,COLORYELLOW;
DRAWICON(XG2,2*DEAA,42);DRAWTEXT(XG2,2*DIFF,'周');
MACD250:=REF(MACD,BARSLAST(MACD=HHV(MACD,250))),COLORA00000,DOTLINE;
XG:=NOT(REF(MACD250,1)=MACD250);
STICKLINE(XG,0,MACD,1,0),COLORYELLOW;
周MACD:(周DIF-周DEA)*2,COLORSTICK,NODRAW;
MA250:=MA(C,250);
DRAWICON(周DIF>=0 AND CROSS(DIF,DEA) AND C>=MA250,2,11);
{跌穿250:=CROSS(MA250,C);
年线之下天数:BARSLAST(跌穿250),NODRAW;}
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1)COLORYELLOW;
D:=SMA(K,3,1),COLORBLUE;
J:=3*K-2*D,COLORWHITE;
月N:=DAY;
月HIGH:=IF(DAY=月N,HHV(H,30),0);
月LOW:=IF(DAY=月N,LLV(L,30),0);
月CLOSE:=IF(DAY=月N,CLOSE,0);
月RSV:=(月CLOSE-LLV(月LOW,72))/(HHV(月HIGH,72)-LLV(月LOW,72))*100;
月K:=SMA(月RSV,3,1),COLORWHITE ;
月D:=SMA(月K,3,1),COLORYELLOW ;
月J:=3*月K-2*月D ;
{DRAWBAND(月K,RGB(255,0,0),月D,RGB(0,0,250));}
周N:=WEEKDAY;
周HIGH:=IF(WEEKDAY=周N,HHV(H,4),0);
周LOW:=IF(WEEKDAY=周N,LLV(L,4),0);
周CLOSE:=IF(WEEKDAY=周N,CLOSE,0);
周RSV:=(周CLOSE-LLV(周LOW,45))/(HHV(周HIGH,45)-LLV(周LOW,45))*100;
周K:=SMA(周RSV,3,1),COLORWHITE ;
周D:=SMA(周K,3,1),COLORYELLOW ;
周J:=3*周K-2*周D,COLORFFFFFF ;
{DRAWBAND(周K,RGB(255,255,0),周D,RGB(0,100,200));}
D1:=1;
{15,POINTDOT,COLOR00FF00;}
B:=C-MA250;
DRAWICON((B>=0 AND CROSS(J,K) AND 月D>=50 AND 周D>=20 AND DIFF>=0),0,1);